The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Topics related to the Grasshopper-ARCHICAD Connection and the various tasks that can be achieved with it.

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

User avatar
By archimax
Hi everyone,

When I first installed and immediately tried GH-connection 2.0 for AC5021 it worked fine. It was several weeks ago and I didn't use it until today.
Now when I try to start GH-connection it says <grasshopper not running>.

I have already tried:
- restarting windows
- reinstalling GH-connection
- reinstalling AC and the latest update
- disabled antivirus
- played with windows firewall
- removed all other GH plugins

Nothing works... :(
Did anyone have this problem before?

Win 10
AC21 5021
Rhino5 SR12
GH 0.9.0076
User avatar
By archimax
I found the problem.
GH-connection is somehow incompatible with GeometryGym plugin.
Both GeometryGym and GH-connectionalso have Newtonsoft.Json.dll that causes the problem. It was tricky to figure out since GeometryGym's files aren't located in default Grasshopper's library folder.
User avatar
By LaszloNagy
I will report this to GRAPHISOFT so they can investigate and hopefully come up with a solution.